4.2.1.3 Packet Tracer – Configuring EtherChannel

Last Updated on April 24, 2018 by Admin

4.2.1.3 Packet Tracer – Configuring EtherChannel

From year to year, Cisco has updated many versions with difference questions. The latest version is version 6.0 in 2018. What is your version? It depends on your instructor creating your class. We recommend you to go thought all version if you are not clear. While you take online test with netacad.com, You may get random questions from all version. Each version have 1 to 10 different questions or more. After you review all questions, You should practice with our online test system by go to "Online Test" link below.

Version 5.02 Version 5.03 Version 6.0 Online Assessment
Chapter 4 Exam Chapter 4 Exam Chapter 4 Exam Online Test
Next Chapter
Chapter 5 Exam Chapter 5 Exam Chapter 5 Exam Online Test  
Lab Activities
 4.2.1.3 Packet Tracer – Configuring EtherChannel
 4.2.2.3 Packet Tracer – Troubleshooting EtherChannel
 4.3.4.4 Packet Tracer – Troubleshoot HSRP
 4.4.1.2 Packet Tracer – Skills Integration Challenge

Packet Tracer – Configuring EtherChannel (Answer Version)

Answer Note: Red font color or Gray highlights indicate text that appears in the Answer copy only.

Topology

4.2.1.3 Packet Tracer – Configuring EtherChannel

4.2.1.3 Packet Tracer – Configuring EtherChannel

Objectives

Part 1: Configure Basic Switch Settings

Part 2: Configure an EtherChannel with Cisco PAgP

Part 3: Configure an 802.3ad LACP EtherChannel

Part 4: Configure a Redundant EtherChannel Link

Background

Three switches have just been installed. There are redundant uplinks between the switches. Usually, only one of these links could be used; otherwise, a bridging loop might occur. However, using only one link utilizes only half of the available bandwidth. EtherChannel allows up to eight redundant links to be bundled together into one logical link. In this lab, you will configure Port Aggregation Protocol (PAgP), a Cisco EtherChannel protocol, and Link Aggregation Control Protocol (LACP), an IEEE 802.3ad open standard version of EtherChannel.

Part 1: Configure Basic Switch Settings

Step 1: Configure basic switch parameters.

a. Assign each switch a hostname according to the topology diagram.

Switch(config)# hostname S1
Switch(config)# hostname S2
Switch(config)# hostname S3

b. Configure all required ports as trunks, depending on the connections between devices.

Note: If the ports are configured with dynamic auto mode, and you do not set the mode of the ports to trunk, the links do not form trunks and remain access ports. The default mode on a 2960 switch is dynamic auto.

S1(config)# interface range g0/1 - 2
S1(config-if-range)# switchport mode trunk
S1(config-if-range)# interface range f0/21 - 22
S1(config-if-range)# switchport mode trunk
S1(config-if-range)# end

 

S2(config)# interface range g0/1 - 2
S2(config-if-range)# switchport mode trunk
S2(config-if-range)# interface range f0/23 - 24
S2(config-if-range)# switchport mode trunk
S2(config-if-range)# end

 

S3(config)# interface range f0/21 - 24
S3(config-if-range)# switchport mode trunk
S3(config-if-range)# end

 

Part 2: Configure an EtherChannel with Cisco PAgP

Note: When configuring EtherChannels, it is recommended to shut down the physical ports being grouped on both devices before configuring them into channel groups. Otherwise, the EtherChannel Misconfig Guard may place these ports into err-disabled state. The ports and port channels can be re-enabled after EtherChannel is configured.

Step 1: Configure Port Channel 1.

a. The first EtherChannel created for this activity aggregates ports F0/22 and F0/21 between S1 and S3. Use the show interfaces trunk command to ensure that you have an active trunk link for those two links.

S1# show interfaces trunk

Port       Mode    Encapsulation    Status        Native vlan
F0/21      on      802.1q           trunking      1
F0/22      on      802.1q           trunking      1
G0/1       on      802.1q           trunking      1
G0/2       on      802.1q           trunking      1

<output omitted>

b. On both switches, add ports F0/21 and F0/22 to Port Channel 1 with the channel-group 1 mode desirable command. The mode desirable option enables the switch to actively negotiate to form a PAgP link.

S1(config)# interface range f0/21 – 22
S1(config-if-range)# shutdown
S1(config-if-range)# channel-group 1 mode desirable
S1(config-if-range)# no shutdown

 

S3(config)# interface range f0/21 - 22
S3(config-if-range)# shutdown
S3(config-if-range)# channel-group 1 mode desirable
S3(config-if-range)# no shutdown

 

c. Configure the logical interface to become a trunk by first entering the interface port-channel number command and then the switchport mode trunk command. Add this configuration to both switches.

Answer Note: Packet Tracer 6.0.1 does not grade the switchport mode trunk command in port-channel interfaces.

S1(config)# interface port-channel 1
S1(config-if)# switchport mode trunk

Answer Note: Packet Tracer 6.0.1 does not grade the switchport mode trunk command in port-channel interfaces.

S3(config)# interface port-channel 1
S3(config-if)# switchport mode trunk

Step 2: Verify Port Channel 1 status.

a. Issue the show etherchannel summary command to verify that EtherChannel is working on both switches. This command displays the type of EtherChannel, the ports utilized, and port states.

S1# show etherchannel summary
Flags:  D - down P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3 S - Layer2
        U - in use f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group   Port-channel    Protocol    Ports
------+-------------+-----------+----------------------------------------
1       Po1(SU)         PAgP        F0/21(P)     F0/22(P)

 

S3# show etherchannel summary
Flags:         D - down            P - in port-channel
               I - stand-alone     s - suspended
               H - Hot-standby (LACP only)
               R - Layer3          S - Layer2
               U - in use          f - failed to allocate aggregator
               u - unsuitable for bundling
               w - waiting to be aggregated
               d - default port


Number of channel-groups in use: 1
Number of aggregators:           1


Group      Port-channel           Protocol       Ports
------+-------------+-----------+----------------------------------------
1          Po1(SU)              PAgP             F0/21(P)    F0/22(P)

 

b. If the EtherChannel does not come up, shut down the physical interfaces on both ends of the EtherChannel and then bring them back up again. This involves using the shutdown command on those interfaces, followed by a no shutdown command a few seconds later.

The show interfaces trunk and show spanning-tree commands also show the port channel as one logical link.

S1# show interfaces trunk
Port    Mode  Encapsulation  Status      Native vlan
Gig0/1  on    802.1q         trunking    1
Gig0/2  on    802.1q         trunking    1
Po1     on    802.1q         trunking    1

<output omitted>

 

S1# show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID     Priority      32769
              Address 0001.436E.8494
              Cost 9
              Port 27(Port-channel 1)
              Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
  Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
              Address 000A.F313.2395
              Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
              Aging Time 20

Interface        Role  Sts  Cost    Prio.Nbr  Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1            Desg FWD    4      128.25    P2p
Gi0/2            Desg FWD    4      128.26    P2p
Po1              Root FWD    9      128.27    Shr

Part 3: Configure an 802.3ad LACP EtherChannel

Step 1: Configure Port Channel 2.

a. In 2000, the IEEE released 802.3ad, which is an open standard version of EtherChannel. Using the previous commands, configure the link between S1 and S2 on ports G0/1 and G0/2 as an LACP EtherChannel. You must use a different port channel number on S1than 1, because you already used that in the previous step. To configure port channel 2 as LACP, use the interface configuration mode channel-group 2 mode active command. Active mode indicates that the switch actively tries to negotiate that link as LACP, as opposed to PAgP.

Answer Note: Packet Tracer 6.0.1 does not grade the switchport mode trunk command in port-channel interfaces.

S1(config)# interface range g0/1 - 2
S1(config-if-range)# shutdown
S1(config-if-range)# channel-group 2 mode active
S1(config-if-range)# no shutdown
S1(config-if-range)# interface port-channel 2
S1(config-if)# switchport mode trunk

 

S2(config)# interface range g0/1 - 2
S2(config-if-range)# shutdwon
S2(config-if-range)# channel-group 2 mode active
S2(config-if-range)# no shutdown
S2(config-if-range)# interface port-channel 2
S2(config-if)# switchport mode trunk

 

Step 2: Verify Port Channel 2 status.

a. Use the show commands from Part 1 Step 2 to verify the status of Port Channel 2. Look for the protocol used by each port.

S1# show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3 S - Layer2
        U - in use f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 2
Number of aggregators:           2

Group   Port-channel  Protocol   Ports
------+-------------+-----------+----------------------------------------------
1       Po1(SU)       PAgP       Fa0/21(P)  Fa0/22(P)
2       Po2(SU)       LACP       Gig0/1(P)  Gig0/2(P)

 

Part 4: Configure a Redundant EtherChannel Link

Step 1: Configure Port Channel 3.

There are various ways to enter the channel-group number mode command:

S2(config)# interface range f0/23 - 24
S2(config-if-range)# channel-group 3 mode ?
  active     Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected

a. On switch S2, add ports F0/23 and F0/24 to Port Channel 3 with the channel-group 3 mode passive command. The passive option indicates that you want the switch to use LACP only if another LACP device is detected. Statically configure Port Channel 3 as a trunk interface.

Answer Note: Packet Tracer 6.0.1 does not grade the switchport mode trunk command in port-channel interfaces.

S2(config)# interface range f0/23 - 24
S2(config-if-range)# shutdown
S2(config-if-range)# channel-group 3 mode passive
S2(config-if-range)# no shutdown
S2(config-if-range)# interface port-channel 3
S2(config-if)# switchport mode trunk

b. On switch S3, add ports F0/23 and F0/24 to Port Channel 3 with the channel-group 3 mode active command. The active option indicates that you want the switch to use LACP unconditionally. Statically configure Port Channel 3 as a trunk interface.

Answer Note: Packet Tracer 6.0.1 does not grade the switchport mode trunk command in port-channel interfaces.

S3(config)# interface range f0/23 - 24
S3(config-if-range)# shutdown
S3(config-if-range)# channel-group 3 mode active
S3(config-if-range)# no shutdown
S3(config-if-range)# interface port-channel 3
S3(config-if)# switchport mode trunk

 

Step 2: Verify Port Channel 3 status.

a. Use the show commands from Part 1 Step 2 to verify the status of Port Channel 3. Look for the protocol used by each port.

S2# show etherchannel summary
<output omitted>
Number of channel-groups in use: 2
Number of aggregators:           2 
Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------
2      Po2(SU)       LACP        Gig0/1(P)   Gig0/2(P)
3      Po3(SU)       LACP        Fa0/23(P)   Fa0/24(P)

b. Port Channel 2 is not operative because spanning tree protocol placed some ports into blocking mode. Unfortunately, those ports were Gigabit ports. To restore these ports, configure S1 to be primary root for VLAN 1 or set the priority to 24576.

S1(config)# spanning-tree vlan 1 root primary
or
S1(config)# spanning-tree vlan 1 priority 24576

From year to year, Cisco has updated many versions with difference questions. The latest version is version 6.0 in 2018. What is your version? It depends on your instructor creating your class. We recommend you to go thought all version if you are not clear. While you take online test with netacad.com, You may get random questions from all version. Each version have 1 to 10 different questions or more. After you review all questions, You should practice with our online test system by go to "Online Test" link below.

Version 5.02 Version 5.03 Version 6.0 Online Assessment
Chapter 4 Exam Chapter 4 Exam Chapter 4 Exam Online Test
Next Chapter
Chapter 5 Exam Chapter 5 Exam Chapter 5 Exam Online Test  
Lab Activities
 4.2.1.3 Packet Tracer – Configuring EtherChannel
 4.2.2.3 Packet Tracer – Troubleshooting EtherChannel
 4.3.4.4 Packet Tracer – Troubleshoot HSRP
 4.4.1.2 Packet Tracer – Skills Integration Challenge